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INTRODUCTION
The Image System is a painting and special effects package which
allows you to create and manipulate pictures on the screen of your
Commodore.
The Image System differs from other painting packages commonly
available in that in addition to the usual facilities provided for drawing, it
also includes a number of sophisticated features opening up a whole new
dimension in home computer art.
When you buy The Image System you also get a facility which will
allow you to manipulate and distort pictures.
The Image System is, therefore, a powerful tool for both artist and
designer.
The possibilities are many, from producing photographs or slides of
computer graphic artwork to creating the graphics for games programs
and visual displays – you can even use The Image System to design your
own clothes, it’s up to you. Have fun!

Getting Started
To load The Image System:
1. Switch on or reset your computer.
2. a) For cassette
i) Place the cassette into the Commodore Data Recorder and ensure
that it is re-wound to the beginning of SIDE A
ii) Type SHIFT/RUN STOP
iii) Press PLAY on the Data Recorder.
b) For Disk
i) Insert disk into disk drive, making sure that the label is facing UP.
ii) Type LOAD "*",8,1 then press the RETURN key.
iii) The program will now LOAD without further intervention.
When The Image System has loaded, you can use either keyboard,
joystick or trackball. It is highly recommended that either trackball or
joystick be used, since the User Interface has been designed with these
devices in mind and is ideally suited to them.
The keys available are as follows:
SPACE
fire
CBM key
replace/remove panel
Control
Draw/panel mode switch
Cursor keys up/down/right/left

A W.I.M.P.S. Environment
You may find the W(indow) I(con) M(enus) P(ointer) Environment
unusual at first since it represents the state-of-the-art in User Interfaces.
Originally a concept created for the Apple Lisa system, the first
WIMP environments were created for use with a mouse. This concept has
been specially adapted for The Image System to work ideally with a
joystick or trackball and is designed for smooth execution of functions
which the normal “on/off” selection does not allow.
For Example
Place the cursor over the DRAW icon and press fire
The Draw menu will now drop down

If you now release fire the menu will disappear and no action will
have been executed nor will any new function have been set.
Press fire again with the icon over the DRAW menu, but keep fire
pressed down. You are free to move the pointer over an icon, let us say
SPRAY PAINT
Now release the fire button. The SPRAY PAINT menu will now drop
down.

You are free to move your pointer over the icons which will light up on
activation; pressing fire will now execute the self-explanatory function.
Moving your pointer over the EXIT icon and pressing fire will set your
function and return you to the panel.
When complimentary functions are chosen, such as the brush select –
the functions of your present operation – say DRAW – will not need to be
reset.
Getting onto the SCREEN
To perform a function once you have made your selection, press
CONTROL. Your cursor will now move to the place on the screen where it
was last used.
Conversely, if on the screen, pressing CONTROL will place the cursor
in the last position it held on the panel.
If you press the CBM key (bottom left of the keyboard) the panel will
disappear to reveal the whole screen, whilst a second depression will
replace it. You will find this facility ideal for evaluating your larger
pictures or working between the two positions of the panel.

Moving THE PANEL
While working on the screen, the panel will move to the opposite
section of the workspace automatically to allow you to fully utilise the
entire screen without the annoyance of having to do the job manually.

Boxes, Images, Rays & Ellipses
To facilitate ease of use The Image System makes certain logical
assumptions about the operation you are performing.
When you have selected BOX and have placed the cursor on the
screen using CONTROL, you may move the pointer freely. When you
press fire once The Image System will fix the first corner of your box.
Moving the cursor will then allow you to “grow” a complete box. Pressing
fire a second time will then fix the box and you are now free to move it
to any part of the screen. You may do this as quickly as you wish since the
box will follow you independently of the cursor, to retain the cursor’s ease
of movement.
Having positioned your box as you require, pressing fire will draw it
on the screen for you. Once again, you are now free to move the box
around the screen should you wish to create additional boxes of the same
size.
For a different box, however, you should return to the panel and
repeat the above procedure.

IMAGE
To define an Image System image, the wimp environment allows you
to be within a box area. Therefore, the same box definition logic can be
employed as above. For Image Distort, things are slightly different and
explained below.
On selecting DISTORT, your cursor will return to its last position on the
screen. From there you can now create the new shape for your defined
image whether it be zoomed, shrunk, folded or changed into 3-D
perspective. Your starting point will be set automatically and the next
three presses of the fire button will mark the remaining corners of the
area. Each subsequent pressing of the button will move you to the
relevant corner thereby changing the shape of the entire box.
This facility of “elastic banding” works in much the same way as the
box function. Pressing CONTROL will fix the shape and return you to the
panel whilst pressing the key a second time will return you to the distort
area to allow further manipulation if required.

The PRINT IMAGE command allows you to move your newly distorted
box around the screen at will and then print it as many times as you may
require until you return to the panel using CONTROL .
On all Image System functions the wimp environment attempts to
eliminate as many repetitive actions as possible. Functions such as RAY,
LINE or STITCH it will make certain assumptions about the operation

involved and performs them automatically. With RAY, for example, all
you need do is select the origin – using fire – and the end of the RAY –
also using fire – and The Image System will complete the operation
returning the cursor to the origin.

Ellipse
When you enter the screen move the cursor to where you want the
centre of the ellipse and press fire; you can define the shape you want. If
you move the cursor you will see The Image System creating an ellipse
relative to your position and your chosen centre. Pressing fire will now fix
the shape and The Image System will re-draw the ellipse at any new
cursor position.
In conclusion
We hope you have now seen how the environment allows you to
simply and easily control the drawing environment with a minimal number
of laborious key presses and that it represents a significant saving of both
time and unproductive effort. Although it may seem strange at first the
Image System user should soon be completely fluid in its operation.

Section 2
Menus and Functions
The Image System has 1 main menu, the panel and eight sub-menus
as follows:
DRAW
IMAGE
BRUSH
TEXTURE
TEXT
PRINT
DISK
SPECIAL
This section will give you an overview of their functions and uses.

The Panel is your entrance to The Image System and its many
complexities and it is through it that all the facilities are chosen,
parameters selected and status monitored.
DRAW

Brush Paint
This function puts The Image System into drawing mode using one of
the brushes defined from the Brush menu.
Spray Paint
This works in the same way as Brush Paint, but allowing you to use an
air brush effect the attributes of which can be defined using the Spray
Paint menu.
Flood Fill
Flood fill will paint any enclosed area with a texture you have
defined from the Texture menu.
>CAUTION! Flood fill means exactly that – if the area is not fully
enclosed the fill will “leak” into the rest of the screen and fill that as well!
The Run/Stop key followed by CONTROL, however, will stop any function
and return you to the panel.
Area Colour
This function sets the screen – within the area you define – to INK 1
and INK 0 colour as defined on the panel.
Colour Scheme
Takes the colour values on OC (Old Colour) and NC (New Colour) as
defined on the panel and will replace new for old whenever the old
colour appears on the section of the screen you define – useful for fiddly
sections!
Colour Copy
Duplicates the overall colour scheme in one area at any other point on
the screen.
Single Line
Using this function you can define a line of pre-determined texture
and brush style of any length or vector and print it around the screen.
Stitch Line
Allows the user to draw consecutive lines of defined texture or brush
of any length or vector from an origin set at the end of the last line
drawn.

Ray Line
This function creates lines drawn from a common chosen origin of any
vector with a defined brush or texture.
See section in WIMP ENVIRONMENT chapter for more information.
Ellipse
Allows the creation of ellipses by the user of any origin and
proportions using any defined brush or texture.
See section in WIMP ENVIRONMENT chapter for more information.
Ellipse Fill
This function lets you draw a filled ellipse in the same way as a nonfilled one, as discussed above.
Box
Creates a rectangular box of any dimensions at any point on the
screen.
See section in WIMP ENVIRONMENT chapter for more information.
Box Fill
As for BOX but filled with any pre-defined colour or texture.
IMAGE

SAVE
Saves images to chosen medium.
LOAD
Loads images from chosen medium.
VERIFY
Checks that images have been SAVEd correctly onto chosen medium.
SELECT
Chooses any one of 15 images available for definition and use.
DEFINE
Defines image area and contents from the screen.
DELETE
Allows image to be deleted or overwritten in the image store while
optimising memory.
DISTORT
Allows a defined section of the screen (selected by Define Image) to
be distorted, zoomed, shrunk, stretched, folded and placed in 3-D
perspective.
PRINT
Allows a distorted image to be printed at any point on the screen
after it has been selected using DEFINE.
BRUSH

SAVE
Allows the user to save brushes to selected medium.
LOAD
LOADs brushes from selected medium.
VERIFY
Verify allows you to check that brushes have been correctly saved
onto your chosen medium.
SELECT
This function allows you to select from any of 16 brushes which are
defined by The Image System and draw on screen.
ORIGIN
Allows the user to define which part of a texture is being drawn by a
brush.
PRINT
Prints the brush as shown on the panel to any part of the screen.
GRAB
Grab brush defines a brush by “grabbing” an area from the screen
and putting it into the current brush.
>CAUTION! The previous brush will be automatically erased.
TEXTURE

SAVE
SAVEs texture to chosen medium.
LOAD
LOADS texture from chosen medium.
VERIFY
Checks texture has been SAVEd correctly.
SELECT
Allows you to choose from 16 available textures for use when
drawing on the screen.
PRINT
Prints textures to any chosen area of the screen.
GRAB
Defines current texture by “grabbing” any pattern displayed on the
screen.
>CAUTION! The previous brush will be automatically erased.
TEXT

SAVE
SAVES text to chosen medium.
LOAD
LOADS text from chosen medium.
VERIFY
Checks text has been SAVEd correctly.
PRINT
Text Print allows the user to print defined patterns as set-up by Text
Grab. You must first define the required font on the screen then grab the
images to allow meaningful use of Text Print. Pressing the appropriate
key on the keyboard will print the pattern allocated by Print Grab at the
screen cursor position.
GRAB
Pressing, for example, the “A” key will define that key as whatever
was contained within the grab area, and when Printing Text (see below),
pressing “A” will then print that grabbed area.
This function allows you to take a text font of any nature you have
designed on the screen and allocate each character to a key on the
keyboard. Having designed your font, Grab creates a character “area”
which, having been defined, can be placed over individual characters.
PRINT

PRINT SCREEN
Print screen allows the user to print the screen to a compatible printer.
>CAUTION! Do not attempt to use this function without a printer attached.
PRINTER
Allows a choice between the two printers supported by The Image
System: The Commodore MPS801 and Epson FX.
LINE FEED
Line Feed allows the user to select either automatic line feed or an
inhibit when printing.
SIZE
Two possible sizes can be selected with this function, standard or
double standard.
INTERFACE
Choose between the Commodore serial interface or Centronics
Parallel interface before printing.
>CAUTION! Make sure you set any relevant parameters before
attempting to print.
DISK

COMMAND
Disk Command allows the user direct control of the disk drive from
within The Image System.
STATUS
Disk Status advises the user on the current status of the disk after
LOADing, SAVEing or VERIFYing and after the use of COMMAND.
SPECIAL

SCREEN SAVE
Saves present screen to a chosen medium.
SCREEN LOAD
Loads a previously saved screen from a chosen medium onto the
current screen.
SCREEN VERIFY
Checks that a screen has been correctly Saved to the chosen medium.
SCREEN CLEAR
Allows the user to delete the entire current screen.
MODE
Mode allows the possibility of working on either a multi-colour or a
standard screen.
It should be noted that the two formats cannot be used simultaneously.
CURSOR SPEED
Enables the user to define the speed at which the cursor will move
across the screen. The higher the value, the lower the speed of the
cursor/pointer.

The Image System
STEP BY STEP

STANDARD SCREEN MODE
Firstly, we need to set a background colour:
Move the cursor to yellow and press fire – the yellow icon will flash. Now
move the cursor to the background colour box in the lower right hand
corner – again, press fire. The small box in the bottom right hand corner
will now flash yellow.
We must now select an ink colour:
Move the cursor to the black icon at the top left of the colour palette and
press fire. The icon will now flash.
You can then move down to the ink icon (to the left of the background
colour icon) and press fire.
The small box in its left-hand corner will now turn to black.
We can now turn to texture.
Move the cursor to the texture icon and hold down the fire button. The
texture menu will now drop down into sight. Move the cursor to SELECT
and release the fire button. The Texture Select menu will now appear.
Move the cursor to UP and press fire. Up will be highlighted and on
pressing fire, the texture will change.
Select, say, texture 6, then move the cursor over EXIT and press fire. The
menu will disappear, leaving texture 6 displayed in the texture window.

We will now select a brush
Pull down the brush menu and, whilst holding down the fire button, move
the cursor to SELECT. Release fire. The Brush Select menu will appear and
in the same way as you chose texture 6, select brush 7.
Move to EXIT and press fire.
The panel should now be displaying the chosen brush.

Press CONTROL to return to the screen.
You will now see a flashing circle which is the new cursor, set in the shape
of your chosen brush. You are free to move it about the screen. Press fire
and you will leave a “trail” of the selected black texture behind in the
shape of your chosen brush.
You can now draw freely – remember, releasing the fire button allows
you to move without drawing, pressing it reinstates the draw status. We
will now clear the screen.
Press CONTROL and return to the panel and pull down the SPECIAL Menu
and select Clear Screen – you will be given a YES or QUIT option in case
you have made a mistake – select YES and the screen will clear.

We will now Create and Distort an image
Pull down the DRAW menu and select Brush Paint then enter screen mode
using CONTROL. Press the CBM key to remove the panel.

Draw a cross (ie an X shape) near the bottom of the screen. Pull down the
Image Menu and select DEFINE. Re-enter screen mode and place the
“elastic box” around the cross, as discussed in the WIMP ENVIRONMENT
chapter. Fix the box and press fire again.

The box will disappear and you can return to the panel (using
CONTROL). Pull down the Image Menu again and select DISTORT. Enter
screen mode and remove panel allowing full sight of the whole screen.

Fix the corners of the Image Distort area into a large rectangle in the top
right hand corner of the screen. Return to the panel.

Pull down the Image Menu and select PRINT. Return to screen and remove
panel.

You can now move the Distort Image area at will around the screen.
Pressing fire will print the image and you should see a scaled up version
of the original. You can Zoom part of this by defining a section of the
whole image as a second image and then scaling it up.

Experimentation with Image Distort will allow you to create numerous
interesting effects and give you a good grasp of the tremendous
capabilities of The Image System.
DON’T BE AFRAID TO EXPERIMENT – remember, you can easily CLEAR the
screen using CLEAR from the panel as described above.

We are now ready to DRAW
Pull down the Draw Menu and select AREA COLOUR. This will now be
printed as a reminder below the brush window. Press CONTROL. The
Image System will switch to screen mode and the cursor will move off the
panel. Guide the cursor to the bottom left corner of the screen. Hold the
fire button down and move the cursor upwards and to the right. An elastic
box will now cover the screen when you reach the top right corner.
Press fire to fix the box.

Press the button again to set the ink and background colours. CONTROL
will now return you to the panel where you can pull down the Draw Menu
and select Brush Paint. This will now replace Area Colour as the message
on the panel.

COLOURS, FILTERS and NEW & OLDS
When you have finished with the Image Menu, clear the screen using the
SPECIAL Menu. Once the screen is clear, move the cursor to the small filter
box ‘little zero’ Press fire. The box will flash.
Now move the cursor over ink colour box 1 and press fire – the small 1
will become a 0 and the filter box will stop flashing. If you now try to
Brush Paint, nothing will appear to happen.
This is because anything that would have been painted in black is now
being painted in yellow – so obviously it doesn’t show up! This is due to
your setting 1 filter to 0 which, in this case, is yellow. Colour zero, as you
can see in the 0 colour Box, is yellow.

Now reset filters: Colour 1 to 1, and Colour 0 to 0.
Place the cursor over the RED icon in the colour palette and press fire. The
icon will flash. Now select Colour 1 and press fire. The colour indicator
icon will now turn red.
You will notice that if you try and paint, the colours have not changed
because except in the zoom window at the left of the panel. To activate
the new colour, use Area Colour to paint all or part of the screen. You will
see it become red without affecting any colours outside that area.

Therefore, if we set both filters 1 and 0 to 1, which is black rather than
yellow, the background colour has been forced to black.
Now set both colour 1 and colour 0 to filter 1 in the same way as before.
Return to screen mode and paint. You will find that you are painting in
solid black. This, of course, means there are four possible permutations:
0
0
Paint in background colour
1
0
Paint in ink on background colour
0
1
Paint in background colour over ink colour
1
1
Paint in ink colour
Please also remember that if the colour indicators are not flashing these
colours are switched off.

Now let’s try New Colour, Old Colour.
Set Icon OC (Old Colour) to black and Icon NC to dark green in the same
way as Colour 1 and Colour 0 were set. Pull down the Draw Menu and
select Colour Scheme. Set the elastic box over the whole screen, starting
from the bottom left corner. Fix the box, and press fire.
You will observe that all the black has changed to green, while leaving
both the yellow background and the red pattern in its own area
unaffected.

GRABBING, BRUSHES & TEXTURE
Grabbing A Texture
Clear the screen
Select Brush 5
Using Texture 10 and Texture 7, draw two over-lapping rectangles.

Select Texture 6
Select Texture Grab

Now enter the screen
Move the cursor over the section where the two textures overlap and
press Fire.

The Texture window will change – and you can select the texture you
want by holding down Fire and moving the cursor.
Returning to the panel will fix the texture.
Now return to the panel and select Brush Paint.
When you paint you will see the new texture displayed in the Texture
Window being painted.
>CAUTION! The old texture will now be destroyed.

Grabbing a Brush
Clear the screen and select Texture 2, Brush 5.
Select Brush Paint and enter the screen.
Draw a horizontal line across the centre of the screen.

Now return to the panel.
Select Brush 4 and select Brush Grab. Re-enter the screen.

Move the cursor over the horizontal line; press fire and locate the white
line over the centre of the Brush Window on the panel.

Returning to the panel will fix the brush.
Select Brush Paint, enter the screen and paint.
You will see that the middle of the texture is not painted when used
horizontally and that the brush works in very much the same way as a pen
nib.

Now try the brush with some other textures.
>CAUTION! Please note that the old Brush 4 will have been destroyed by
the new. You can, however, SAVE your Brushes and Textures to either your
Cassette player or disk drive and use them later.
By now you should be proficient enough – and familiar enough – with The
Image System and its’ concepts and controls to venture off on your own
and explore some of the many exciting features of the system.
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